PAT (Advanced Level) Practice 1133 Splitting A Linked List

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Puppettt/article/details/82144458

1133 Splitting A Linked List(25 分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10​5​​,10​5​​], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

思路:开结构体直接记小于0,小于等于K大于0,大于K的部分,再分部输出。

注意可能不存在某个部分,最后要以-1结束

‘代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5;
struct node{
    int add,v,next;
    int now;
}lin[maxn],l[maxn],i[maxn],r[maxn];
int lcnt=0,icnt=0,rcnt=0;
int fid,N,K;
void check(int now)
{
    if(lin[now].v<0)l[lcnt++]=lin[now];
    else if(lin[now].v<=K)i[icnt++]=lin[now];
    else r[rcnt++]=lin[now];
}
int main()
{

    scanf("%d%d%d",&fid,&N,&K);
    int a,v,b;
    for(int j=0;j<N;j++)
    {
        scanf("%d%d%d",&a,&v,&b);
        lin[a].now=a;
        lin[a].v=v;
        lin[a].next=b;
    }
    int next=lin[fid].next;
    lcnt=0,icnt=0,rcnt=0;
    check(fid);
    while(next!=-1)
    {
        check(next);
        next=lin[next].next;
    }

    for(int j=0;j<lcnt;j++)
    {
        if(j<lcnt-1)
        printf("%05d %d %05d\n",l[j].now,l[j].v,l[j+1].now);
        else
        {
        	int pos=-1;
			if(icnt>0)pos=i[0].now;
			else if(rcnt>0)pos=r[0].now; 
			if(pos==-1)printf("%05d %d -1\n",l[j].now,l[j].v);
			else
            printf("%05d %d %05d\n",l[j].now,l[j].v,pos);
        }
    }
    for(int j=0;j<icnt;j++)
    {
        if(j<icnt-1)
            printf("%05d %d %05d\n",i[j].now,i[j].v,i[j+1].now);
        else{
        	int pos=-1;
        	if(rcnt>0)pos=r[0].now;
        	if(pos==-1)printf("%05d %d -1\n",i[j].now,i[j].v);
            else
			printf("%05d %d %05d\n",i[j].now,i[j].v,pos);
        }
    }
    for(int j=0;j<rcnt;j++)
    {
        if(j<rcnt-1)
            printf("%05d %d %05d\n",r[j].now,r[j].v,r[j+1].now);
        else
            printf("%05d %d -1\n",r[j].now,r[j].v);
    }
}

猜你喜欢

转载自blog.csdn.net/Puppettt/article/details/82144458