U - Primes

题目:

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes. 

Input

Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000. 

Output

The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no". 

Sample Input

1
2
3
4
5
17
0

Sample Output

1: no
2: no
3: yes
4: no
5: yes
6: yes

题意:

给你一个数字,让你判断这个数是否是素数,如果是素数,就输出yes,否则输出no;

这道题有一个大坑,那就是当这个数小于等于0时结束!!!!!

在这一点错了三次的我,一万点委屈!

算了,下次看题要仔细了。。。。。

思路:

素数打表;

代码如下:

#include<stdio.h>
#include<string.h>
#define N 20000

int n;
int prime[N];

void init()
{
    int i,j;
    memset(prime,0,sizeof prime);
    prime[1]=1;
    for(i=2; i<=N; i++)
    {
        if(prime[i]==0)
        {
            for(j=2; j*i<=N; j++)
            {
                prime[i*j]=1;
            }
        }
    }
    return ;
}

int main()
{
    int k=1;
    init();
    while(~scanf("%d",&n))
    {
        if(n<=0)//重点!!!!!
            break;
        if(n==1)
            printf("%d: no\n",k++);
        else if(n==2)
            printf("%d: no\n",k++);
        else
        {
            if(prime[n]==0)
                printf("%d: yes\n",k++);
            else
                printf("%d: no\n",k++);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/82108103