F - Elven Postman

题目:

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods. 

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture. 

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited. 

Your task is to determine how to reach a certain room given the sequence written on the root. 

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree. 

Input

First you are given an integer T(T≤10)T(T≤10) indicating the number of test cases. 

For each test case, there is a number n(n≤1000)n(n≤1000) on a line representing the number of rooms in this tree. nn integers representing the sequence written at the root follow, respectively a1,...,ana1,...,an where a1,...,an∈{1,...,n}a1,...,an∈{1,...,n}. 

On the next line, there is a number qq representing the number of mails to be sent. After that, there will be qq integers x1,...,xqx1,...,xq indicating the destination room number of each mail.

Output

For each query, output a sequence of move (EE or WW) the postman needs to make to deliver the mail. For that EE means that the postman should move up the eastern branch and WW the western one. If the destination is on the root, just output a blank line would suffice. 

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1

Sample Output

E

WE
EEEEE

题意:

给你一个T,代表有T组测试数据,给你一个n,代表有n个字母,让你构成一个二叉搜索树,然后给你一个m,后面一行有m个数字,让你查找这些数字的位置,输出路径,在二叉搜索树中如果是向左输出“E”,否则输出“W”,注意,如果和根节点相等就不输出,所以第二行中才会没有任何输出,做题的时候纠结了半天才看懂题意。

思路:

首先我们要建立一个二叉搜索树,使用链表会简单一点,这是我第一次使用链表,纪念一下吧。

使用链表建立二叉搜索树,把每个数字按照二叉搜索树的特点依次插入,然后开始搜索要查询的数字,别的也没有什么可以说的了。

代码如下:

#include<stdio.h>
#include<string.h>

int t,n,m,k,a,b;

struct node
{
    int date;
    struct node *left;//链表中下一个左子树的位置;
    struct node *right;//链表中下一个右子树的位置;
};

void insert(node * &root,int aa)
{
    if(root==NULL)//如果找到了空位置就把数字插入;
    {
        root=new node;//将叶子节点拓展一个新的拥有左右子树的节点;
        root->date=aa;//存进去;
        root->left=NULL;//左右子树应该为空;
        root->right=NULL;
    }
    if(root->date<aa)//根据二叉搜索树的概念,大的在右;
        insert(root->right,aa);
    if(root->date>aa)//晓得在左;
        insert(root->left,aa);
}

void find(node * &root,int bb)//查找;
{
    if(root->date<bb)//大的向右;
    {
        printf("W");
        find(root->right,bb);
    }
    if(root->date>bb)//小的向左;
    {
        printf("E");
        find(root->left,bb);
    }
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int i;
        node *root=NULL;//建立一个根节点;
        for(i=0; i<n; i++)
        {
            scanf("%d",&a);
            insert(root,a);
        }
        scanf("%d",&m);
        for(i=0; i<m; i++)
        {
            scanf("%d",&b);
            find(root,b);
            printf("\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/81903143
F