HDU-1702 ACboy needs your help again! 解题报告

HDU - 1702

题目描述

ACboy needs your help again!

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :” I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy.”
The problems of the monster is shown on the wall:
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

题目大意

题目提供两种输入输出方式:FIFO和FILO,当输入为IN时,输入并保存一个整数,当输入为OUT时,输出保存的整数数,若没有,则输出None。测试数据包括n组,n在输入开头读入。

解题方法

简单的队列和栈的应用
这两种输入输出方式分别为队列和栈,FIFO <-> 队列,FILO <-> 栈,使用queue和stack头文件即可,因此只要将读入的数据存入队列或栈,在输入OUT时,读走队头、栈顶元素即可。

代码如下

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <stack>
#include <string>
using namespace std;
int N, n, num;
char IorO[10] = {0};
char way[10] = {0};
queue<int> q;
stack<int> s;
int main()
{
    scanf("%d", &N);
    for(int i = 0; i < N; i ++)
    {
        scanf("%d%s", &n, way);
        if(strcmp(way, "FIFO") == 0)
        {
            for(int j = 0; j < n; j ++)
            {
                scanf("%s", IorO);
                if(strcmp(IorO, "IN") == 0)
                {
                    scanf("%d", &num);
                    q.push(num);
                }
                else if(strcmp(IorO, "OUT") == 0)
                {
                    if(q.empty())
                        printf("None\n");
                    else
                    {
                        printf("%d\n", q.front());
                        q.pop();
                    }
                }
            }
        }
        else if(strcmp(way, "FILO") == 0)
        {
            for(int j = 0; j < n; j ++)
            {
                scanf("%s", IorO);
                if(strcmp(IorO, "IN") == 0)
                {
                    scanf("%d", &num);
                    s.push(num);
                }
                else if(strcmp(IorO, "OUT") == 0)
                {
                    if(s.empty())
                        printf("None\n");
                    else
                    {
                        printf("%d\n", s.top());
                        s.pop();
                    }
                }
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41480330/article/details/82561281