zoj-1004Anagrams by Stack(栈和向量)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/shadowcw/article/details/75671064
Anagrams by Stack

Time Limit: 2 Seconds      Memory Limit: 65536 KB

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]
and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

Process

A stack is a data storage and retrieval structure permitting two operations:

We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]
题意:将第一个字符串转化为第二个字符串用栈来模拟i表示存放进栈,o表示取出栈 把所有可能都列出来 代码如下 用s来模拟字符的进栈与出栈 operate来保存操作 dfs来实现所有可能
 
 
#include<iostream>
#include<string>
#include<cstring>
#include<stack>
#include<vector>
using namespace std;
string a,b;
int len;
vector<char> operate;
stack<char> s;
void dfs(int ipush,int ipop)
{
    if(ipush==ipop&&ipush==len)
    {
        for(int i=0;i<len;i++)
        {
            cout<<operate[i]<<" ";
        }
        cout<<endl;
    }
    if(ipush+1<=len)
    {
        s.push(a[ipush]);
        operate.push_back('i');
        dfs(ipush+1,ipop);
        s.pop();
        operate.pop_back();
    }
    if(ipop+1<=ipush&&ipop+1<=len&&s.top()==b[ipop])
    {
        char t=s.top();
        operate.push_back('o');
        s.pop();
        dfs(ipush,ipop+1);
        s.push(t);
        operate.pop_back();
    }
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>a>>b)
    {
        cout<<"["<<endl;
        len=a.size();
        dfs(0,0);
        cout<<"]"<<endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/shadowcw/article/details/75671064