Buy and Resell

版权声明:小白一个,欢迎各位指错。 https://blog.csdn.net/qq_36424540/article/details/82080087

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n

cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

Input

There are multiple test cases. The first line of input contains a positive integer T

(T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105

.

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output

16 4
5 2
0 0


        
  

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. 
         
  profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. 
         
  profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. 
         
  profit = 0

        
 
#include<bits/stdc++.h>
using namespace std;

#define rep(i,a,b) for(int i=a;i<b;i++)
typedef long long LL;

const int N=1e5+10;

LL val[N];

unordered_map<LL,int> vis;

/*
我觉得最神奇的地方,莫过于把一个点 当成是两个点了。
这样的话,如果我们反悔,后面发现更好的,我们就可以利用向量的概念直接跳跃,略去中间商
恐怕贪心也是不好想
*/
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        vis.clear();

        int n;
        scanf("%d",&n);
        rep(i,1,n+1)scanf("%lld",&val[i]);

        LL ans=0,time=0;
        priority_queue<LL,vector<LL>,greater<LL> >q;
        for(int i=1;i<=n;i++){
            if(!q.empty()){
                LL tmp=q.top();
                if(tmp<val[i]){
                    q.pop();
                    ans+=val[i]-tmp;
                    if(vis[tmp]){
                        q.push(tmp);
                        vis[tmp]--;
                    }
                    else{
                        time+=2;
                    }
                    vis[val[i]]++;
                    //printf("i:%d tmp:%lld ans:%lld time:%lld\n",i,tmp,ans,time);
                }
            }
            q.push(val[i]);
        }
        printf("%lld %lld\n",ans,time);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36424540/article/details/82080087