poj—简单dfs输入坑

版权声明: https://blog.csdn.net/jianbagengmu/article/details/79477782

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2

mean 寻找有多少个‘@’块;
ans
dfs;
坑:
5 5 后有一个空格;
输入scanf(“%d %d\n”);是正确 输入法 ,若是用getchar()吸收就会gg 补充 …%*c 多读一次字符,不分配空间

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define ll long long
char mp[111][111];
void dfs(int i,int j)
{
    if(mp[i][j]=='*')
        return ;
    mp[i][j]='*';
    //调用递归把与'@'相连的'@'都变成'*'
    dfs(i-1,j-1);
    dfs(i-1,j);
    dfs(i-1,j+1);
    dfs(i,j-1);
    dfs(i,j+1);
    dfs(i+1,j-1);
    dfs(i+1,j);
    dfs(i+1,j+1);
}
int main()
{
    int n,m,i,j;
    while(~scanf("%d %d\n",&n,&m)&&n)
    {
        // getchar();

        memset(mp,'*',sizeof(mp));

        for(i=1; i<=n; i++)
        {

            for(j=1; j<=m; j++)
                scanf("%c",&mp[i][j]);
            //  scanf("%s",mp[i]+1);
            getchar();
        }
        //   puts("11111111111111111111111");
        /*    for(i=1;i<=n;i++)
            {

                for(j=1;j<=m;j++)
                cout<<mp[i][j];
                puts("");
            }*/
        int cnt=0;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=m; j++)
            {
                if(mp[i][j]=='@')
                {
                    dfs(i,j);
                    cnt++;
                }
            }
        }
        cout<<cnt<<endl;
    }

}





















猜你喜欢

转载自blog.csdn.net/jianbagengmu/article/details/79477782