暑假训练 Battle City (OpenJ_Bailian - 2312)bfs +优先队列

描述:
Many of us had played the game “Battle city” in our childhood, and some people (like me) even often play it on computer now.
在这里插入图片描述
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).
在这里插入图片描述
Your tank can’t move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
Input
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of ‘Y’ (you), ‘T’ (target), ‘S’ (steel wall), ‘B’ (brick wall), ‘R’ (river) and ‘E’ (empty space). Both ‘Y’ and ‘T’ appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the turns you take at least in a separate line. If you can’t arrive at the target, output “-1” instead.
Sample Input
3 4
YBEB
EERE
SSTE
0 0
Sample Output
8

代码:

#include<cstdio>
#include<string.h>
#include<queue>

using namespace std;
const int maxn = 1e3 + 5;
int n, m, vis[maxn][maxn], dx[4] = {-1, 0, 0, 1}, dy[4] = {0, -1, 1, 0};
char x[maxn][maxn];

struct tank
{
    int x, y, time;
    friend bool operator < (tank a, tank b)
    {
        return a.time > b.time;
    }
};

void solve(int a, int b)
{
    memset(vis, 0, sizeof vis);
    priority_queue<tank> q;
    tank st = {a, b, 0};
    q.push(st);
    while(!q.empty())
    {
        st = q.top();
        q.pop();
        if(x[st.x][st.y] == 'T')
        {
            printf("%d\n", st.time);
            return ;
        }
        for(int i = 0; i < 4; i++)
        {
            int tx = st.x + dx[i];
            int ty = st.y + dy[i];
            if(tx < 0 || tx >= n || ty < 0 || ty >= m || x[tx][ty] == 'R' || x[tx][ty] == 'S')continue;
            if(!vis[tx][ty])
            {
                tank tp = {tx, ty, st.time + 1};
                if(x[tx][ty] == 'B')++tp.time;
                q.push(tp);
                vis[tx][ty] = 1;
            }
        }
    }
    printf("-1\n");
}

int main()
{
    while(scanf("%d%d", &n, &m), n||m)
    {
        int a, b;
        for(int i = 0; i < n; i++)
        {
            getchar();
            for(int j = 0; j < m; j++)
            {
                char y;
                scanf("%c", &y);
                x[i][j] = y;
                if(y == 'Y')
                {
                    a = i;
                    b = j;
                }
            }
        }
        solve(a, b);
    }
    return 0;
}

坦克大战和魂斗罗就是我的童年啊。。看着太亲切了。
傻傻的先用dfs写,然后T,发现要用bfs…然后用了队列后发现WA了,有点懵。
终于借助了网友的力量后发现要用优先队列,因为B墙可能会使用时加一,比如
EB
ET
从左上角走到右下角就应先把左下弹出,,,看了别人的代码才发现。。。

猜你喜欢

转载自blog.csdn.net/wbl1970353515/article/details/82821372