PAT:A1085 Perfect Sequence (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Ecloss/article/details/82664729

PAT:A1085 Perfect Sequence (25 分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where Mand m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn = 100010;

int main() {
	long long a[maxn], ans = 1, M, p;
	cin >>M>>p; 
	for(int i = 0; i < M; i++) {
		cin>>a[i];
	}
	sort(a, a+M);
   for (int i = 0; i < M; ++i) {
        for (int j = i+ans-1; j < M;++j){
            if (a[j] <= a[i]*p) {
                if (j-i+1 > ans) {
                    ans = j - i + 1;
                }
            }else{
                break;
            }
        }
    }
	cout << ans;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ecloss/article/details/82664729