UVA_11059 Maximum Product

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
you should consider 0 as the value of the maximum product.
Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
is
an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
element in the sequence. There is a blank line after each test case. The input is terminated by end of
file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
M is the number of the test case, starting from 1, and P is the value of the maximum product. After
each test case you must print a blank line.
Sample Input
3
2 4 -3
5
2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.
#include<cstdio>
#include<iostream>
using namespace std;
int num[200];

int main(){
	int n,m,val,cnt=0;
	while(scanf("%d",&n)!=EOF&&n){
		long long ans=0;
		for(int i=0;i<n;i++)
			cin>>num[i];
		for(int i=1;i<=n;i++){
			for(int j=0;j<=n-i;j++){
				long long temp=1;
				for(int k=j;k<j+i;k++)	temp*=num[k];
				if(temp>ans)	ans=temp;	
			} 	
		}
		printf("Case #%d: The maximum product is %lld.\n\n", ++cnt, ans);
	}
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/larry1648637120/article/details/82944578