OJ-2751 指针练习--字符串统计

2751: 指针练习--字符串统计

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 228   Solved: 145
[ Submit][ Status][ Web Board]

Description

实现一个统计函数。统计字符串中大写字母、小写字母和其他字符的个数。

主函数已给定如下,提交时不需要包含下述主函数
int main()
{
    char str[80];
    int numA,numa,numt;
    cin.getline(str,80);
    count(str,&numA,&numa,&numt);
    cout<<"大写字母个数为 "<<numA<<endl
        <<"小写字母个数为 "<<numa<<endl
        <<"其他字符个数为 "<<numt<<endl;
    return 0;
}

Input

一行字符串

Output

大写字母、小写字母和其他字符的个数

Sample Input

WVGA:800*480,HDTV:1080i,33.75kHz

Sample Output

大写字母个数为 9
小写字母个数为 3
其他字符个数为 20

//注意运算符的优先级

#include<iostream>
#include<cstring>
using namespace std;
void count(char str[80],int *numA,int *numa,int *numt);
int main()
{
    char str[80];
    int numA,numa,numt;
    cin.getline(str,80);
    count(str,&numA,&numa,&numt);
    cout<<"大写字母个数为 "<<numA<<endl
        <<"小写字母个数为 "<<numa<<endl
        <<"其他字符个数为 "<<numt<<endl;
    return 0;
}
void count(char str[80],int *numA,int *numa,int *numt)
{
    *numA=0;*numa=0;*numt=0;
    int n=strlen(str);
    for(int i=0;i<n;i++)
    {
        if(str[i]>='A'&&str[i]<='Z')
            *numA+=1;
        else if(str[i]>='a'&&str[i]<='z')
            *numa+=1;
        else
            *numt=*numt+1;
    }
    return ;
}


猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/80917827