盒子(Box, ACM/ICPC NEERC 2004, UVa1587)

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box. Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake. Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.

Input

Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet and contains two integer numbers w and h (1 ≤ w, h ≤ 10 000) — width and height of the pallet in millimeters respectively.

Output

For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it is possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not possible to do so.

Sample Input

1345 2584

2584 683

2584 1345

683 1345

683 1345

2584 683

1234 4567

1234 4567

4567 4321

4322 4567

4321 1234

4321 1234

Sample Output

POSSIBLE

IMPOSSIBLE

代码

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

typedef struct 
{
	int w,l;
} Pallet;

bool cmp(Pallet a,Pallet b)
{
	return a.w<b.w||(a.w==b.w&&a.l<b.l);
}

int main()
{
	Pallet p[6];
	int a,b;
	while(~scanf("%d %d",&a,&b))
	{
		int flag=1;
		if(a>b)
		{
			p[0].l=a;
			p[0].w=b;
		}
		else
		{
			p[0].l=b;
			p[0].w=a;
		}
		for(int i=1; i<6; i++)
		{
			scanf("%d %d",&a,&b);
			if(a>b)
			{
				p[i].l=a;
				p[i].w=b;
			}
			else
			{
				p[i].l=b;
				p[i].w=a;
			}
		}
		sort(p,p+6,cmp);
		for(int i=0;i<6;i+=2)
		{
			if(p[i].w!=p[i+1].w||p[i].l!=p[i+1].l) flag=0;
		}
		if(p[0].w!=p[2].w||p[0].l!=p[4].w||p[2].l!=p[4].l) flag=0;
		printf(flag?"POSSIBLE\n":"IMPOSSIBLE\n");
	}
}

猜你喜欢

转载自blog.csdn.net/qq_41667282/article/details/81140044