(3)C - map

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
Hint

Huge input and output,scanf and printf are recommended.


题意:输入单词,再输入其对应的单词,以空行为标志,在输入测试数据,输出对应的单词,如果不存在,则输出eh。用map<string,string>。比较水的map。

#include<iostream>
#include<cstdio>
#include<map>
#include<algorithm>
#include<string>
using namespace std;
char a[100],b[100],c[100];
int main()
{
 map<string,string>m;
 while(gets(a)&&a[0]!='\0')
 {
  sscanf(a,"%s%s",b,c);
  m[c]=b;
 }
 while(gets(c))
 {
  if(m.find(c)==m.end())
  {
   cout<<"eh"<<endl;
  }
  else
  {
   cout<<m[c]<<endl;
  }
 }
 return 0; 
}

猜你喜欢

转载自blog.csdn.net/whhhzs/article/details/79392570