(2)U - 贪心

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that
  • each bin contains at most 2 items,
  • each item is packed in one of the q bins,
  • the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q .
Input
The first line of the input contains the number of items n (1<=n<=10 5) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.
Output
Your program has to write the minimal number of bins required to pack all items.
Sample Input
10
80
70
15
30
35
10
80
20
35
10
30
Sample Output
6
Hint

The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.

题意:给出n个长度l1,l2,,ln,和容量为的容器,每个容器能放一个或两个元素,求装下这些元素的最小m。
思路:注释。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[100000];
bool cmp(int x,int y)
{
 return x>y;//排序
}
int main()
{
 int n,l,i,j,sum;
 while(cin>>n)
 {
  cin>>l;
  sum=0;
  for(i=0;i<n;i++)
  {
   cin>>a[i];
  }
  sort(a,a+n,cmp);
  for(i=0,j=n-1;i<=j;)
  {
   if(a[i]+a[j]<=l)//如果加起来小于等于l,则i++,j++
   {
    i++,j--,sum++;
   }
   else
   {
    i++,sum++;
   }
  }
  cout<<sum<<endl;
 }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/whhhzs/article/details/79380494