PAT甲级1016 (map,排序)

题目

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 – 01:00, the toll from 01:00 – 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word “on-line” or “off-line”.

For each test case, all dates will be within a single month. Each “on-line” record is paired with the chronologically next record for the same customer provided it is an “off-line” record. Any “on-line” records that are not paired with an “off-line” record are ignored, as are “off-line” records not paired with an “on-line” record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80


题解

首先判断是否成对,最后还是用到了map。
成对的话,上线要在下线前。这边上下线用staus记录。加在结构体里。
每组测试数据,所有日期在同一个月,故记录时间时考虑day,hour,min。

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
struct customer{
  string name;
  int month,day,hour,min,time,status;//考虑好哪些因素,比如cost和total不在结构体里
};
bool cmp(customer a,customer b){
  return a.name==b.name?a.time<b.time:a.name<b.name;
}

double count(customer call,int *cost){
  double total=cost[call.hour]*call.min+call.day*cost[24]*60;
  for(int i=0;i<call.hour;i++){
    total+=cost[i]*60;
  }
  
  return total/100.0;
}
int main(){
  int cost[25]={0};
  for(int i=0;i<24;i++){
    scanf("%d",&cost[i]);
    cost[24]+=cost[i];
  }
  int n;
  scanf("%d",&n);
  vector<customer> cus(n);
  for(int i=0;i<n;i++){
    //不能数据类型分开输入
    cin>>cus[i].name;
    scanf("%02d:%02d:%02d:%02d",&cus[i].month,&cus[i].day,&cus[i].hour,&cus[i].min);
    string temp;
    cin>>temp;
    cus[i].status=(temp=="on-line")?1:0;//这样可以少用if了
    //因为date的数据都在里面,可以顺便算个通话时间,后面是用挂电话分钟数-接电话分钟数
    cus[i].time=cus[i].day*24*60+cus[i].hour*60+cus[i].min;
  }
  sort(cus.begin(),cus.end(),cmp);
  map<string,vector<customer>> result;
  for(int i=1;i<n;i++){
    if(cus[i].name==cus[i-1].name&&cus[i-1].status==1&&cus[i].status==0){
      result[cus[i-1].name].push_back(cus[i-1]);
      result[cus[i].name].push_back(cus[i]);
    }
    
  }
  // 输出
  for(auto it:result){
   // vector auto::iterator it;
    vector<customer> temp=it.second;//加入map的倒入新的vector遍历完准备输出
    //printf(*it.first);
    cout<<it.first;
    printf(" %02d\n",temp[0].month);
    double total=0.0;
    for(int i=1;i<temp.size();i+=2){
      double t=count(temp[i],cost)-count(temp[i-1],cost);
      printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",temp[i-1].day,temp[i-1].hour,temp[i-1].min,temp[i].day,temp[i].hour,temp[i].min,temp[i].time-temp[i-1].time,t);
      total+=t;
    }
    printf("Total amount: $%.2f\n",total);
    
  }
  return 0;
}

本题最重要的是两个vector和一个map的运用,map也可以象有序容器一样push_back。
还有双重排序,先排名字,再按名字排时间。
这题犯了不少错。比如输入输出格式:%02d老写成02%d。
最致命的错就是,当输入字符串时,最好用cin格式,用scanf显示段错误。
多加注意!

猜你喜欢

转载自blog.csdn.net/qq_24572475/article/details/82875125