1044 Shopping in Mars (25 分)(二分查找)

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105​​ ), the total number of diamonds on the chain, and M (≤10​8​​ ), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​ ⋯D​N​​ (D​i​​ ≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题目大意

给一串序列,求子序列的和等于m的所有子序列,若找不到这样的子序列,则找子序列和大于m并且接近m的子序列。

分析

本题第一次提交时有两个测试点超时,后来参考博客1,该博客也遇到相同的超时问题,但是最后发现sum数组是单调递增的,于是采用二分查找,最后AC~

 #include <iostream>
#include <vector>
using namespace std;
vector<int> v,sum;
int n,m;
void func(int i,int &j,int &tmpsum){
	int left=i,right=n,mid;
	while(left<right){
		mid=(left+right)/2;
		tmpsum=sum[mid]-sum[i]+v[i];
		if(tmpsum>=m) right=mid;
		else left=mid+1;
	}
	j=right;
	tmpsum=sum[j]-sum[i]+v[i];
} 
int main() {
	
	cin>>n>>m;
	v.resize(n),sum.resize(n);
	for(int i=0; i<n; i++) {
		cin>>v[i];
		if(i==0) sum[i]=v[i];
		else sum[i]=sum[i-1]+v[i];
	}
	bool flag=false;
	int minM=sum[n-1];
	vector<int> a,b;
	for(int i=0; i<n; i++) {
		int j,tmpsum;
		func(i,j,tmpsum);
		if(tmpsum>minM) continue;
		if(tmpsum>=m){
			if(tmpsum<minM) {
				a.clear(),b.clear();
				minM=tmpsum;
			}
			a.push_back(i+1),b.push_back(j+1);
		}
	}
	for(int i=0;i<a.size();i++){
		printf("%d-%d\n",a[i],b[i]);
	}
	return 0;
}

  1. https://www.liuchuo.net/archives/2939 ↩︎

猜你喜欢

转载自blog.csdn.net/whutshiliu/article/details/83020832