UVALive-7188 Almost Sorted Array (最长上升子序列)

We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection
sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.
We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We
say an array is almost sorted if we can remove exactly one element from it, and the remaining array is
sorted. Now you are given an array a1, a2, . . . , an, is it almost sorted?
Input
The rst line contains an integer T indicating the total number of test cases. Each test case starts with
an integer n in one line, then one line with n integers a1, a2, . . . , an.
• 1 ≤ T ≤ 2000
• 2 ≤ n ≤ 105
• 1 ≤ ai ≤ 105
• There are at most 20 test cases with n > 1000.
Output
For each test case, please output `YES' if it is almost sorted. Otherwise, output `NO' (both without
quotes).
Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
Sample Output
YES
YES
NO

题意

给一个长度为n的序列,求去掉其中一个元素后不会不会成为不增或者不降序列。

思路

这题就是求最长上升子序列,相反的时候用reverse函数反转一下数组就可以了。具体参考这个链接

AC代码

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <queue>
#include <cmath>
#include <map>
#include <list> 
#define ll long long
using namespace std;

const int mod = 1e9+7;
const int maxn = 1e6+5;

int a[maxn];
int temp[maxn];
int main()
{
    int T;
	scanf("%d",&T);
	while (T--){
		int n,flag = 1;
		scanf("%d",&n);
		for (int i = 1; i<=n; i++){
			scanf("%d",&a[i]);
		}
		int Max=1;   //用来记录上升数的个数 
        memset(temp,0x3f,sizeof(temp));    //把temp数组设成无穷大 
        temp[0]=-1;
        for(int i=1;i<=n;i++)
        {
            int pos=upper_bound(temp,temp+n,a[i])-temp;    //第一个大于a[i]的坐标 
            temp[pos]=a[i];
            Max=max(Max,pos);
        }
        memset(temp,0x3f,sizeof(temp));
        temp[0]=-1;
        reverse(a+1,a+n+1);//反转数组,用于下降子序列 
        for(int i=1;i<=n;i++)
        {
            int pos=upper_bound(temp,temp+n,a[i])-temp;
            temp[pos]=a[i];
            Max=max(Max,pos);
        }
        if(Max>=n-1) puts("YES");
        else puts("NO");

		
	} 
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Gamer_Lee/article/details/81776384