POJ 2255

Tree Recovery

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17060   Accepted: 10481

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 
 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 
 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

Source

Ulm Local 1997

扫描二维码关注公众号,回复: 3581659 查看本文章

大致题意:

给出二叉树的前序遍历和中序遍历,输出二叉树的后序遍历。

解题思路:

二叉树前序遍历的首字符是二叉树的根,

中序遍历中位于该字符左边的是左子树的中序遍历,右边是右子树的中序遍历。

首先找出根节点,然后递归求解左右子树,最后输出根节点字符。

代码:

#include<iostream>
#include<string.h>
using namespace std;
char pre[30],in[30];
void revoer(int prel,int prer,int inl,int inr)
{
	if(prel<=prer&&inl<=inr)
	{
		int i,root;
		for(root=0;root<=inr;root++)
		{
			if(pre[prel]==in[root])
				break;
		}
		int leftsize=root-inl;
		int rightsize=inr-root;
		if(leftsize>0)
			revoer(prel+1,prel+leftsize,inl,root-1);
		if(rightsize>0)
			revoer(prer-rightsize+1,prer,root+1,inr);
		cout<<in[root];
	}
 
}
int main()
{
	
	while(cin>>pre>>in)
	{
		int prechang=strlen(pre);
		int inchang=strlen(in);
        revoer(0,prechang-1,0,inchang-1);
		cout<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40421671/article/details/82829624
POJ