hdu1232(并查集求强连通)

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。 

Sample Input

 

4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0

Sample Output

 

1 0 2 998

Hint

Hint Huge input, scanf is recommended.

Source

浙大计算机研究生复试上机考试-2005年

并查集求强连通分量,求后再减去1

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 5005

int father[maxn];
int ans[maxn];
int n,m,sum;
int find(int x)
{
    if(father[x]!=x)
    father[x]=find(father[x]);
    return father[x];
}

void bind(int u,int v)
{
    int f1=find(u);
    int f2=find(v);
    if(f1!=f2)
    {
        father[f2]=f1;
        sum--;
    }

}

int main()
{while(scanf("%d",&n))
{if(n==0)
break;
scanf("%d",&m);
for(int i=1;i<=n;i++)
father[i]=i;

     sum=n-1;
    int x,y;
    for(int i=1;i<=m;i++)
    {scanf("%d%d",&x,&y);
   bind(x,y);
    }
   printf("%d\n",sum);
}
return 0;

}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/83045474