Idiomatic Phrases Game ZOJ - 2750 (hush + dj/bl)

版权声明: https://blog.csdn.net/nucleare/article/details/81544856

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 1010;

struct TA_ {
	int f, s, w;
} ta[maxn];
 
int dis[maxn], in[maxn], cnt;
int a[maxn][maxn];

int val(char c) {
	if (c >= '0' && c <= '9')
	return c - '0';
	else 
	return (c - 'A') + 10;
}

void hash(char *str, int &f, int &s) {
	
	int len = strlen(str);
//	register unsigned char *p1 = (unsigned char *)str;
//	register unsigned char *p2 = (unsigned char *)&str[len-4];
//    int i;
//	for(i = 0; i < 4; ++i, ++p1)
//		f = 31 * f + *p1;
//   	for(i = 0; i < 4; ++i, ++p2)
//		s = 31 * s + *p2;
	// 为什么*30^ ?  难道是字符个数?  
	f = val(str[0]) * 27000 + val(str[1]) * 900 + val(str[2]) * 30 + val(str[3]);
	s = val(str[len-4]) * 27000 + val(str[len-3]) * 900 + val(str[len-2]) * 30 + val(str[len-1]); 
}

int main(void) {
	
	int n;
	while (~scanf ("%d", &n) && n) {
		
		int c;
		char str[1010];
		for (int i = 1; i <= n; ++i) {
			scanf("%d %s", &ta[i].w, str);
			hash(str, ta[i].f, ta[i].s);
		}
		cnt = 0;
		
		for (int i = 1; i <= n; ++i) {
			for (int j = 1; j <= n; ++j) {
				a[i][j] = INF;
				if (i != j && ta[i].s == ta[j].f) {
					a[i][j] = ta[i].w;
				}
			}
		}
		
		
		for (int i = 1; i <= n; ++i) dis[i] = a[1][i];
		memset(in, 0, sizeof(in));
		dis[1] = 0, in[1] = 1;
		for (int j = 1; j < n; ++j){
			int min_d = INF, min_i;
			for (int i = 1; i <= n; ++i) {
				if (!in[i] && dis[i] < min_d) {
					min_d = dis[i];
					min_i = i;
				}
			}
			in[min_i] = 1;
			for (int i = 1; i <= n; ++i) {
				if (!in[i] && a[min_i][i] < INF && dis[i] > dis[min_i] + a[min_i][i]) {
					dis[i] = dis[min_i] + a[min_i][i];
				}
			}
		}
		
		if (dis[n] < INF) printf("%d\n", dis[n]);
		else puts("-1");
		
	}
	
	return 0;
} 

bellman_ford

#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 1010;

int val(char c) {
	if (c >= '0' && c <= '9')
	return c - '0';
	else 
	return (c - 'A') + 10;
}

void hash(char *str, int &f, int &s) {
	
	int len = strlen(str);
//	register unsigned char *p1 = (unsigned char *)str;
//	register unsigned char *p2 = (unsigned char *)&str[len-4];
//    int i;
//	for(i = 0; i < 4; ++i, ++p1)
//		f = 31 * f + *p1;
//   	for(i = 0; i < 4; ++i, ++p2)
//		s = 31 * s + *p2;
	// 为什么*30^ ?  难道是字符个数?  
	f = val(str[0]) * 27000 + val(str[1]) * 900 + val(str[2]) * 30 + val(str[3]);
	s = val(str[len-4]) * 27000 + val(str[len-3]) * 900 + val(str[len-2]) * 30 + val(str[len-1]); 
}

struct TA_ {
	int f, s, w;
} ta[maxn];

int u[maxn], v[maxn], w[maxn], dis[maxn], cnt;
int a[maxn][maxn];


int main(void) {
	
	int n;
	while (~scanf ("%d", &n) && n) {
		
		char str[1010];
		for (int i = 1; i <= n; ++i) {
			scanf("%d %s", &ta[i].w, str);
			hash(str, ta[i].f, ta[i].s);
		}
		cnt = 0;
		for (int i = 1; i <= n; ++i) {
			for (int j = 1; j <= n; ++j) {
				a[i][j] = INF;
				if (i != j && ta[i].s == ta[j].f) {
					a[i][j] = ta[i].w;
				}
			}
		}
		memset(dis, 0x3f, sizeof(dis));
		dis[1] = 0;
		for (int k = 1; k < n; ++k) {
			int flag = 1;
			for (int i = 1; i <= n; ++i) {
				for (int j = 1; j <= n; ++j) {
					if (a[i][j] < INF && dis[j] > dis[i] + a[i][j]) {
						dis[j] = dis[i] + a[i][j];
						flag = 0;
					}
				}
			}
			if (flag) break;
		}
		
		
		if (dis[n] != INF) printf("%d\n", dis[n]);
		else puts("-1");
		
	}
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/nucleare/article/details/81544856