1097. Deduplication on a Linked List (25)【链表】——PAT (Advanced Level) Practise

版权声明:本文为博主原创文章,转载请标明出处 http://blog.csdn.net/xianyun2009 https://blog.csdn.net/xianyun2009/article/details/51407860

题目信息

1097. Deduplication on a Linked List (25)

时间限制300 ms
内存限制65536 kB
代码长度限制16000 B
Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10^4, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

解题思路

链表标记连接节点

AC代码

#include <cstdio>
#include <set>
#include <map>
#include <vector>
using namespace std;
set<int> st;
map<int, pair<int, int> > mp;
vector<int> v;
int main()
{
    int first, n, a, b, k;
    scanf("%d%d", &first, &n);
    for (int i = 0; i < n; ++i){
        scanf("%d%d%d", &a, &k, &b);
        mp[a] = make_pair(k, b);
    }
    int p = first;
    while (p != -1){
        printf("%05d %d ", p, mp[p].first);
        st.insert(abs(mp[p].first));
        p = mp[p].second;
        while (p != -1 && st.find(abs(mp[p].first)) != st.end()){
            v.push_back(p);
            p = mp[p].second;
        }
        if (~p) printf("%05d\n", p);
    }
    printf("-1\n");
    if (!v.empty()){
        printf("%05d %d ", v[0], mp[v[0]].first);
        for (int i = 1; i < v.size(); ++i){
            printf("%05d\n%05d %d ", v[i], v[i], mp[v[i]].first);
        }
        printf("-1\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xianyun2009/article/details/51407860