2015长春区域赛 - L - House Building HDU - 5538

版权声明:随便写写,也不重要,欢迎挑错讨论 https://blog.csdn.net/qq_37305947/article/details/82657798

ave you ever played the video game Minecraft? This game has been one of the world's most popular game in recent years. The world of Minecraft is made up of lots of 1×1×11×1×1 blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material such as brick or concrete in this game. 

Figure 1: A typical world in Minecraft.
Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it's really a lovely place to build houses on it. Nyanko-san decided to build on a n×mn×m big flat ground, so he drew a blueprint of his house, and found some building materials to build. 

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected. 

There are nn rows and mm columns on the ground, an intersection of a row and a column is a 1×11×1 square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san's blueprint can be represented as an integer array ci,j(1≤i≤n,1≤j≤m)ci,j(1≤i≤n,1≤j≤m). Which ci,jci,j indicates the height of his house on the square of ii-th row and jj-th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san's house(exclude the face adjacent to the ground).

Input

The first line contains an integer TT indicating the total number of test cases. 
First line of each test case is a line with two integers n,mn,m. 
The nn lines that follow describe the array of Nyanko-san's blueprint, the ii-th of these lines has mm integers ci,1,ci,2,...,ci,mci,1,ci,2,...,ci,m, separated by a single space. 

1≤T≤501≤T≤50 
1≤n,m≤501≤n,m≤50 
0≤ci,j≤10000≤ci,j≤1000

Output

For each test case, please output the number of glass units you need to collect to meet Nyanko-san's requirement in one line.

Sample Input

2
3 3
1 0 0
3 1 2
1 1 0
3 3
1 0 1
0 0 0
1 0 1

Sample Output

30
20

Figure 2: A top view and side view image for sample test case 1.

扫描二维码关注公众号,回复: 3832229 查看本文章

题意:没有自己翻译,但是队友解释的清楚,给一个矩阵,每个格子的数字代表该地有几个正方体落在一起,最后求表面积(不加底面);

思路:十分简单,先按一行来处理,eg:2 3 4 6 8 5 3这个矩阵的表面积 分为三部分左右 和前后 和上面,

可以把这一行扩展成:

                        0 0 0 0 0 0 0 0 0

                        0 2 3 4 6 8 5 3 0

                        0 0 0 0 0 0 0 0 0

单看左右只需每一个减去前一个 取绝对值 再累计求和即可 即每次加上露出来的面积:2+1+1+2+2+3+2+3

前后同理,上面积只需看矩阵里哪里有数就加一就可以。

#include<bits/stdc++.h>
#define CaseT int t;scanf("%d",&t);while(t--)
#define ms(a,x) memset(a,x,sizeof(a))
using namespace std;

#define N 107
#define MAX 100002

typedef long long ll;

int n,m;
int mapp[N][N];
void solve(){
	scanf("%d%d",&n,&m);
	ms(mapp,0);
	int res=0;
	for(int i=1;i<=n+1;i++){
		for(int j=1;j<=m+1;j++){
			if(i!=n+1 && j!=m+1)
				scanf("%d",&mapp[i][j]);
			res+=abs(mapp[i][j]-mapp[i-1][j]);
			res+=abs(mapp[i][j]-mapp[i][j-1]);
			
			if(mapp[i][j])	res++;
		}
	}
	printf("%d\n",res);
} 
int main(){
	CaseT
	solve();
	return 0;
}

有一个小优化的 地方 也没快很多.....两个for循环嵌套变成一个for循环嵌套。emmmm主要是这种思路~我觉得我很厉害 哈哈哈哈哈

猜你喜欢

转载自blog.csdn.net/qq_37305947/article/details/82657798