#153-[背包DP]手链

版权声明:反正也没有人会转,下一个 https://blog.csdn.net/drtlstf/article/details/83587988

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

有N(1 ≤ N ≤ 3,402) 件物品和一个容量为V的背包。第i件物品的重量是w[i](1 ≤ Wi ≤ 400),价值是d[i](1 ≤ Di ≤ 100)。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量M(1 ≤ M ≤ 12,880),且价值总和最大。

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

第一行:物品个数N和背包大小M

第二行至第N+1行:第i个物品的重量w[i]和价值d[i]

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

输出一行最大价值。

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
// 一道水题

#include <iostream>

#define SIZE 13010

using namespace std;

int dp[SIZE];

int main(void)
{
	int t, n, i, w, c;
	
	scanf("%d%d", &n, &t);
	while (n--)
	{
		scanf("%d%d", &w, &c);
		for (i = t; i >= w; --i)
		{
			dp[i] = max(dp[i], dp[i-w] + c); // 条件转移方程
		}
	}
	
	printf("%d", dp[t]);
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/drtlstf/article/details/83587988