FANG FANG

Fang Fang says she wants to be remembered. I promise her. We define the sequence F of strings.
F0 = “f”,
F1 = “ff”,
F2 = “cff”,
Fn = Fn−1 + “f”, for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends. Spell the serenade using the minimum number of strings in F,or nothing could be done but put her away in cold wilderness.

输入

An positive integer T, indicating there are T test cases. Following are T lines, each line contains an string S as introduced above. The total length of strings for all test cases would not be larger than 106 .

输出

The output contains exactly T lines. For each test case, if one can not spell the serenade by using the strings in F, output −1. Otherwise, output the minimum number of strings in F to split S according to aforementioned rules.
Repetitive strings should be counted repeatedly.

样例输入

8
ffcfffcffcff
cffcfff
cffcff
cffcf
ffffcffcfff
cffcfffcffffcfffff
cff
cffc

样例输出

Case #1: 3
Case #2: 2
Case #3: 2
Case #4: -1
Case #5: 2
Case #6: 4
Case #7: 1
Case #8: -1

提示

Shift the string in the first test case, we will get the string “cffffcfffcff”and it can be split into “cffff”, “cfff” and “cff”.

题意:

C_{0}= ' f ' ,    C_{1}=' ff '     ,C_{2}= 'cff ' ,  C_{3}=' cfff '   . . . . . . .  C_{n}=C_{n-1}+ ' f ‘;

给定一组可以成环的字符串,问其可有几个上述字段组成。

分析:分段判断即可

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long int
char maze[1000010];
int main()
{
    int f,sum,node=1;
    scanf("%d",&f);
    while(f--){
        sum=0;
        memset(maze,'\0',sizeof(maze));
        scanf("%s",maze);
        int l=strlen(maze);

        int flag=1,num;
        for(int i=0;i<l&&flag;i++){
            if(maze[i]!='c'&&maze[i]!='f')
                flag=0;
        }

        int countt=0;
        while(maze[countt]!='c'&&countt<l)
            countt++;

        if(countt>=l){
            printf("Case #%d: %d\n",node,(l+1)/2);
            node++;
            continue;
        }

        int k;
        for(int t=countt;t<l&&flag;){
            k=t+1;
            while(k<l&&maze[k]!='c')
                k++;
            int temp=k-t-1;
            if(k>=l)
                temp+=countt;
            if(temp<2){
                flag=0;
                break;
            }
            t=k;
            sum++;
        }

        if(flag==0)
            printf("Case #%d: -1\n",node);
        else
            printf("Case #%d: %d\n",node,sum);
        node++;
    }


    return 0;
}

猜你喜欢

转载自blog.csdn.net/dong_qian/article/details/82917163