HDU-1325-Is It A Tree?(并查集)

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

InputThe input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
OutputFor each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


思路:

判断有向图是否为有向树的关键:1.连通图(只有一个根节点) 2.无环 3.每个节点入度为1(根节点为0)。

也就是说,1.最后只有一个集合 2.合并的时候不能合并一个集合的两个节点 3.合并的时候子节点入度为0(子节点为根节点或子节点还未并入树)。

坑点:

1.这个题如果有一个入度为1的节点加一个父节点,虽然代码上改子节点的编码还是一个,但实际图上已经有两个父节点了!所以必须单独判断一下入度是否已经为1!

2.这个题没给数据范围,开1005就够。

3.节点合并方向要注意一下,是x是y的父节点。

玄学:

用C++编译时,flag=0放在pre[]初始化之间就会WA。我也是醉了。

纪念一下WA15次的题T^T


#include<cstdio>
#include<cstring>
using namespace std;

int pre[1005];
int mark[1005];
int flag;

int find(int x){
    while(pre[x]!=x){
        int r=pre[x];
        pre[x]=pre[r];
        x=r;
    }
    return x;
}

void merge(int x,int y){
    int fx=find(x);
    int fy=find(y);
    if(fy!=fx) pre[fy]=fx;//注意 
}

int main(){
    int x,y;
    int no=1;
    while(1){
    
        memset(mark,0,sizeof(mark));
        for(int i=1;i<=1005;i++)
           pre[i]=i;
        flag=0;
        
        while(scanf("%d%d",&x,&y)){        
            if(x<0&&y<0) return 0;
            if(x==0&&y==0) break; 
            if(find(x)==find(y)||find(y)!=y) flag=1;//两个判断条件缺一不可 
            else merge(x,y);
            mark[x]=1,mark[y]=1;
          }
          
        int cnt=0;
        for(int i=1;i<=1005;i++)
            if(mark[i]&&find(i)==i) cnt++;                
        if(cnt>1) flag=1;
        if(flag) printf("Case %d is not a tree.\n",no++);
        else printf("Case %d is a tree.\n",no++);    
    }
    
    return 0;
} 

猜你喜欢

转载自www.cnblogs.com/yzhhh/p/9951455.html