A - Visiting Peking University

Ming is going to travel for n days and the date of these days can be represented by n integers: 0, 1, 2, …, n-1. He plans to spend m consecutive days(2 ≤ m ≤ n)in Beijing. During these m days, he intends to use the first day and another day to visit Peking university. Before he made his plan, Ming investigated on the number of tourists who would be waiting in line to enter Peking university during his n-day trip, and the results could be represented by an integer sequence p[i] (0 ≤ i ≤ n-1, p[i] represents the number of waiting tourists on day i). To save time, he hopes to choose two certain dates a and b to visit PKU(0 ≤ a < b ≤ n-1), which makes p[a] + p[b] as small as possible.

Unfortunately, Ming comes to know that traffic control will be taking place in Beijing on some days during his n-day trip, and he won’t be able to visit any place in Beijing, including PKU, on a traffic control day. Ming loves Beijing and he wants to make sure that m days can be used to visit interesting places in Beijing. So Ming made a decision:  spending k (m ≤ k ≤ n) consecutive days in Beijing is also acceptable if there are k - m traffic control days among those k days. Under this complicated situation, he doesn’t know how to make the best schedule. Please write a program to help Ming determine the best dates of the two days to visit Peking University.  Data guarantees a unique solution.

Input

There are no more than 20 test cases.

For each test case:

The first line contains two integers, above mentioned n and m (2 ≤ n ≤ 100, 2 ≤ m ≤ n).

The second line contains n integers, above mentioned p[0] , p[1] , … p[n-1]. (0 ≤ p[i] ≤ 1000, i = 0 ... n-1)

The third line is an integer q (0 ≤ q ≤ n), representing the total number of traffic control days during the n-day trip, followed by q integers representing the dates of these days.

Output

One line, including two integers a and b, representing the best dates for visiting PKU.

Sample Input

7 3
6 9 10 1 0 8 35
3 5 6 2
4 2
10 11 1 2
1 2

Sample Output

0 3
1 3

思路:每次找到符合条件的p[i]和p[j],(在i,j中有m天可以出行),比较mx和p[i]+p[j]的大小,找到最小的。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1200;
const int INF = 99999999; 
int vis[maxn],p[maxn],m,n;
int main(void)
{
	int i,j,k,x,mx,t1,t2,a,b,fg,ans,num;
	while(~scanf("%d%d",&n,&m))
	{
		memset(vis,0,sizeof(vis));
		ans=INF;a=0;b=0;
		for(i=0;i<n;i++) scanf("%d",&p[i]);
		scanf("%d",&k);
		for(i=0;i<k;i++) scanf("%d",&x),vis[x]=1;
		for(i=0;i<n;i++)
		{
			if(vis[i]==0)
			{
				mx=INF;
				num=1;fg=0;
				for(j=i+1;j<n;j++)
				{
					if(vis[j]==0)
					{
						if(mx>p[i]+p[j])
						{
							mx=p[i]+p[j];
							t1=i;t2=j;
						}
						num++;
						if(num>=m)
						{
							fg=1;break;
						}
					}
				}
				if(ans>mx&&fg)
				{
					ans=mx;
					a=t1;b=t2;
				}
			}
		}
		printf("%d %d\n",a,b);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41829060/article/details/83827408