poj 1365 Prime Land (数学--唯一分解定理)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/bmicnj/article/details/67651825


Prime Land
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 4098   Accepted: 1856

Description

Everybody in the Prime Land is using a prime base number system. In this system, each positive integer x is represented as follows: Let {pi}i=0,1,2,... denote the increasing sequence of all prime numbers. We know that x > 1 can be represented in only one way in the form of product of powers of prime factors. This implies that there is an integer kx and uniquely determined integers e kx, e kx-1, ..., e 1, e 0, (e kx > 0), that   The sequence 

(e kx, e kx-1, ... ,e 1, e 0



is considered to be the representation of x in prime base number system. 

It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division is very simple. 

Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been decided to make an experiment and let a computer to do the operation ``minus one''. 

Help people in the Prime Land and write a corresponding program. 

For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi. 

Input

The input consists of lines (at least one) each of which except the last contains prime base representation of just one positive integer greater than 2 and less or equal 32767. All numbers in the line are separated by one space. The last line contains number 0.

Output

The output contains one line for each but the last line of the input. If x is a positive integer contained in a line of the input, the line in the output will contain x - 1 in prime base representation. All numbers in the line are separated by one space. There is no line in the output corresponding to the last ``null'' line of the input.

Sample Input

17 1
5 1 2 1
509 1 59 1
0

Sample Output

2 4
3 2
13 1 11 1 7 1 5 1 3 1 2 1


给出x的因数唯一分解的底数和指数,问x-1的因数分解的底数和指数。

定理:唯一分解定理--质因数。

素数筛:判定是否为素数

快速乘:当指数很大时用快速乘,很快

分解质因数,从大到小找质因数

代码:

#include <iostream>
#include<cstdio>
#include<string>
#include<sstream>
#include<cstring>
using namespace std;
#define MAXN 32767+10
int prime[MAXN];
int p[MAXN],e[MAXN];
long long sum;
//素数筛
void init()
{
    memset(prime,0,sizeof(prime));
    prime[1]=1;
    for(int i=2;i*i<=MAXN;i++)
    {
        if(!prime[i])
        {
            for(int j=i*i;j<=MAXN;j+=i)
                prime[j]=1;
        }
    }
}
//快速乘
long long QuickMul(int a,int b)
{
    long long ans=1;
    int base=a;
    int e=b;
    while(e)
    {
        if(e&1) ans*=base;
        base=base*base;
        e=e>>1;
    }
    return ans;
}
int main()
{
    init();
    string s;
    int P,E;
    while(getline(cin,s)&&s!="0")
    {
        stringstream ss(s);
        sum=1;
        while(ss>>P>>E)
        {
            sum*=QuickMul(P,E);
        }
        sum--;     
        //因数分解   
        int p[MAXN],e[MAXN];
        memset(p,0,sizeof(p));
        memset(e,0,sizeof(e));
        int cnt=0;
        for(int i=MAXN;i>=2&&sum>1;i--)
        {
            if(!prime[i]&&sum%i==0)
            {
                while(sum%i==0)
                {
                    p[cnt]=i;
                    e[cnt]++;
                    sum/=i;
                }
                cnt++;
            }
        }
        if(cnt)
        {
            for(int i=0;i<cnt;i++)
            {
                if(i==0)
                    printf("%d %d",p[i],e[i]);
                else
                    printf(" %d %d",p[i],e[i]);
            }
            printf("\n");
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/bmicnj/article/details/67651825