python 找对称数

【问题描述】已知10个四位数输出所有对称数及个数 n,例如1221、2332都是对称数
【输入形式】10个四位数,以空格分隔开
【输出形式】输入的四位数中的所有对称数,对称数个数
【样例输入】1221 2243 2332 1435 1236 5623 4321 4356 6754 3234
【样例输出】1221 2332 2

def is_duicheng(n):
    n_str = str(n)
    return n_str[0] == n_str[3] and n_str[1] == n_str[2]
    
    # if n_str[0] == n_str[3] and n_str[1] == n_str[2]:   > 复杂处理
    #     return True
    # else:
    #     return False

#读入10个整数
line = input().split()
nums = []
for s in line:
    nums.append(int(s))
#print("nums=", nums)

duicheng_list = []
for n in nums:
    if is_duicheng(n):
        duicheng_list.append(n)

for d in duicheng_list:
    print(d, end=' ')
print(len(duicheng_list))

猜你喜欢

转载自blog.csdn.net/qq_37752067/article/details/84311982