PAT 1028 List Sorting (25 分)关于 Cin Cout 最后一个测试实例超时 燚

版权声明:哈哈 你能采纳 我很开心 https://blog.csdn.net/m0_38090681/article/details/84191433

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

 大意:按给定信息将列表排序

输入:第一行:N为输入的数据(N小于等于100000),C为按第几列排序

          后面N行:ID 姓名  分数

输出:将列表按第C列从小到大排序  如果出现C列有两个或者以上相等的情况则按ID号由小到大进行排序

思想:分三种情况定义3个比较函数

坑点:1.如果用C++ 中的std::cin>>和std::cout<<最后一个测试样例运行超时。

           2.在main()函数中定义数组array[100000]可能 会爆栈。

知识点:在函数中定义的数组实在栈中  但系统栈是有限的,所以如果数组太大会爆掉,因此可以将他定义在函数之外作为全局变量,全局变量存储在静态存储区。(如有错误请留言,欢迎指正)。

#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<stdio.h>
using namespace std;
struct Student{
	char id[10];
	char name[10];
	int grade;
};
Student student[100001];
void input(int n){
	for(int i=0;i<n;i++){
		scanf("%s%s%d",student[i].id,student[i].name,&student[i].grade);

	}
}
int compare1(Student &a,Student &b){
	return strcmp(a.id,b.id)<0;
}
int compare2(Student &a,Student &b){
	if(strcmp(a.name,b.name))
		return strcmp(a.name,b.name)<0;
	return strcmp(a.id,b.id)<0;
} 
int compare3(Student &a,Student &b){
	if(a.grade!=b.grade)
		return a.grade<b.grade;
	return strcmp(a.id,b.id)<0;
}
int main(){
	int n,c;
	scanf("%d%d",&n,&c);
	input(n);
	switch(c){
		case 1:sort(student,student+n,compare1);break;
		case 2:sort(student,student+n,compare2);break;
		case 3:sort(student,student+n,compare3);break;
	}
	for(unsigned int i=0;i<n;i++){
		printf("%s %s %d\n",student[i].id,student[i].name,student[i].grade);
	}
}

猜你喜欢

转载自blog.csdn.net/m0_38090681/article/details/84191433