Seaside

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/windywo/article/details/47858829

Time Limit : 2000/1000ms (Java/Other)
Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 96
Accepted Submission(s) : 51

Problem DescriptionXiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

InputThere are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S[sub]Mi[/sub] and L[sub]Mi[/sub], which means that the distance between the i-th town and the S[sub]Mi[/sub] town is L[sub]Mi[/sub].

OutputEach case takes one line, print the shortest length that XiaoY reach seaside.

Sample Input5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1

Sample Output
2

简单的求最小生成树,floyd

#include<cstdio>
#include<algorithm>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
int flag[12],cost[12][12];
int n,sum;
void floyd()
{
    int i,j,k; 
    for(k=0;k<n;k++)
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                if(cost[i][j]>cost[i][k]+cost[k][j])
                    cost[i][j]=cost[i][k]+cost[k][j];
}
int main()
{
    while(~scanf("%d",&n))
    {
        int a,b,i,j,m,p;
        for(i=0;i<n;i++)
        for(j=0;j<n;j++)
            cost[i][j]=inf;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&m,&p);
            flag[i]=(p==0?0:1);
            while(m--)
            {
                scanf("%d%d",&a,&b);
                if(b<cost[i][a])
                    cost[i][a]=cost[a][i]=b;
            }
        }
        sum=inf;
        floyd();
        for(i=0;i<n;i++)
        {
            if(flag[i])
            sum=min(sum,cost[0][i]);
        }
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/windywo/article/details/47858829