HDOJ字符串统计

Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
 
Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
 
Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
 
Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf
 
Sample Output
6
9
 
Author
lcy
 
#include <stdio.h>
#include <string.h>
int main()
{
    int n, i, len, j, sum;
    char  a[100];
    while(scanf("%d", &n)!=EOF)
    {
        getchar();
        for(i=1; i<=n; i++)
        {
            gets(a);
            len=strlen(a);
            sum=0;
            for(j=0; j<len; j++)
            {
                if(a[j]>='0' && a[j]<='9')
                {
                    sum++;
                }
            }
            printf("%d\n", sum);
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/center-cc/p/10014730.html