【POJ】3620Avoid The Lakes(求联通块的最大值)

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9009   Accepted: 4737

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

Source

USACO 2007 November Bronze

题目大意:给出一个N*M的图,其中还有K个点是有水珠的,问你这这水珠组成的最大联通块中有多少水珠。

思路:DFS搜索联通块,判断好边界条件,保存最大值,问题不大。。。、

代码:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#define maxn 1001
using namespace std;

int R,C,K;
int cnt,ans;
char mp[maxn][maxn];

void dfs(int x,int y)
{
    if(x<1||x>R||y<1||y>C||mp[x][y]==0)
        return ;

    cnt++;
    mp[x][y]=0;
    dfs(x+1,y);
    dfs(x,y+1);
    dfs(x-1,y);
    dfs(x,y-1);
}


int main()
{
    while(scanf("%d%d%d",&R,&C,&K)==3)
    {
        for(int i=1; i<=R; i++)
            for(int j=1; j<=C; j++)
                mp[i][j]=0;
        while(K--)
        {
            int i,j;
            scanf("%d%d",&i,&j);
            mp[i][j]=1;
        }
        ans=0;
        for(int i=1; i<=R; i++)
            for(int j=1; j<=C; j++)
                if(mp[i][j]==1)
                {
                    cnt=0;
                    dfs(i,j);
                    ans=max(ans,cnt);
                }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/84350871