6168 Problem A Speech Patterns (25)

问题 A: Speech Patterns (25)

时间限制: 1 Sec  内存限制: 32 MB
提交: 247  解决: 70
[提交][状态][讨论版][命题人:外部导入]

题目描述

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

输入

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入

Can1: "Can a can can a can?  It can!"

样例输出

can 5
#include<cstdio>
#include<iostream>
#include<map>
#include<cstdlib>
#include<string>
using namespace std;

int main(){
	string a;
	while (getline(cin, a)) {
		map<string, int> mp;
		string str;
		for (int i = 0; i < a.length();) {
			str = "";
			while (!isalnum(a[i]) && i < a.length()) {
				i++;//isalnum判断是否为字母or数字
			}
			while (isalnum(a[i]) && i < a.length()) {
				str += tolower(a[i]);//若大写字母转小写
				i++;
			}
			mp[str]++;
		}
		int num = -1;
		for (map<string, int>::iterator it = mp.begin(); it != mp.end(); it++) {
			if (it->second > num){
				num = it->second;
				str = it->first;
			}
		}
		cout << str << " " << num << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36502291/article/details/84485840