Java——Shift Dot(点的位移)

版权声明:叁土 https://blog.csdn.net/qq_42847312/article/details/83247205

Shift Dot
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
给出平面直角坐标系中的一点,并顺序给出n个向量,求该点根据给定的n个向量位移后的位置。

Input
多组输入,第一行是三个整数x,y,n,表示点的坐标(x,y),和向量的个数n。接下来n行,每行两个数xi,yi,表示第i个向量。题目中所有数据不会超出整形范围。

Output
每组输入输出一行,"(x,y)"表示点的最终位置。

Sample Input
0 0 1
2 3
0 0 2
1 2
2 3

Sample Output
(2,3)
(3,5)

AC代码:

import java.util.Scanner;

class Point {
	int x, y;

	public Point(int x, int y) {
		this.x = x;
		this.y = y;
	}

	public Point move(int x, int y) {  //每次输入便更新一次电
		this.x += x;
		this.y += y;
		return new Point(this.x, this.y);
	}
}

public class Main {
	public static void main(String[] args) {
		Scanner mi = new Scanner(System.in);
		while (mi.hasNext()) {
			Point p = new Point(mi.nextInt(), mi.nextInt());
			int n = mi.nextInt();
			for (int i = 0; i < n; i++) {
				p = p.move(mi.nextInt(), mi.nextInt());
			}
			System.out.println("(" + p.x + "," + p.y + ")");
		}
		mi.close();
	}
}

——————
余生还请多多指教!

猜你喜欢

转载自blog.csdn.net/qq_42847312/article/details/83247205
dot