POJ2864 Pascal Library【模拟】

Pascal Library

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6541   Accepted: 3032

Description

Pascal University, one of the oldest in the country, needs to renovate its Library Building, because after all these centuries the building started to show the effects of supporting the weight of the enormous amount of books it houses. 

To help in the renovation, the Alumni Association of the University decided to organize a series of fund-raising dinners, for which all alumni were invited. These events proved to be a huge success and several were organized during the past year. (One of the reasons for the success of this initiative seems to be the fact that students that went through the Pascal system of education have fond memories of that time and would love to see a renovated Pascal Library.) 

The organizers maintained a spreadsheet indicating which alumni participated in each dinner. Now they want your help to determine whether any alumnus or alumna took part in all of the dinners.

Input

The input contains several test cases. The first line of a test case contains two integers N and D indicating respectively the number of alumni and the number of dinners organized (1 <= N <= 100 and 1 <= D <= 500). Alumni are identified by integers from 1 to N. Each of the next D lines describes the attendees of a dinner, and contains N integers Xi indicating if the alumnus/alumna i attended that dinner (Xi = 1) or not (Xi = 0). The end of input is indicated by N = D = 0.

Output

For each test case in the input your program must produce one line of output, containing either the word `yes', in case there exists at least one alumnus/alumna that attended all dinners, or the word `no' otherwise.

Sample Input

3 3
1 1 1
0 1 1
1 1 1
7 2
1 0 1 0 1 0 1
0 1 0 1 0 1 0
0 0

Sample Output

yes
no

Hint

Alumna: a former female student of a particular school, college or university. 
Alumnus: a former male student of a particular school, college or university. 
Alumni: former students of either sex of a particular school, college or university.

扫描二维码关注公众号,回复: 4347838 查看本文章

Source

South America 2005

问题链接:POJ2864 Pascal Library

问题描述:给你一个n,d。n表示参加聚会的人数,d表示聚会的举办次数。要你求出是否有人出席了全部的聚会,有的话就输出yes,不然输出no。

解题思路:简单模拟,a[i]表示第i个人参加的聚会数,具体看程序。

AC的C++程序:

#include<iostream>
#include<cstring>

using namespace std;

const int N=105;

int a[N];

int main()
{
	int n,d;
	while(~scanf("%d%d",&n,&d)&&(n||d))
	{
		memset(a,0,sizeof(a));
		for(int i=1;i<=d;i++)//遍历d场聚会
		{
			for(int j=1;j<=n;j++)
			{
				int x;
				scanf("%d",&x);
				a[j]+=x;//第i个人参加的聚会数 	
			}
		}
		bool flag=false;
		for(int i=1;i<=n;i++)
		  if(a[i]==d)
		  {
		  	flag=true;
		  	break;
		  }
		printf("%s\n",flag?"yes":"no");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/84655116