程序设计基础69 STL之map

1100 Mars Numbers (20 分)

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

一,注意点

1,要学会使用getline(cin,str),同时还要学会使用substr(start,len),start为开始的下标,len为截取的长度。

2,本题最好的方法是把0到168这些数字进行打表,对输入的例子直接查询即可。由于时间原因,不再给出这种最好方法。

二,我的代码

#include<iostream>
#include<string>
#include<map>
using namespace std;
string single[14] = { "tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec" };
string decimal[14] = { "tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou" };
map<string, int> mars_single;
map<string, int> mars_decimal;
int str_to_num(string str) {
	int len = str.length();
	int ans = 0;
	for (int i = 0; i < len; i++) {
		ans = ans * 10 + str[i] - '0';
	}
	return ans;
}
int main() {
	int N = 0;
	string factor;
	int factor_1 = 0;
	for (int i = 0; i < 13; i++) {
		mars_single[single[i]] = i;
	}
	for (int i = 0; i < 13; i++) {
		mars_decimal[decimal[i]] = i;
	}
	scanf("%d", &N);
	getchar();
	for (int i = 0; i < N; i++) {
//		getchar();
		getline(cin, factor);
		if (factor[0] >= '0'&&factor[0] <= '9') {
			factor_1 = str_to_num(factor);
			if (factor_1 / 13 != 0) {
				cout << decimal[factor_1 / 13];
				if (factor_1 % 13 != 0) {
					cout << " "<<single[factor_1 % 13] << endl;
				}
				else {
					cout << endl;
				}
			}
			else {
				cout <<single[factor_1 % 13] << endl;
			}
		}
		else{
			int ans = 0;
			string mars_shi, mars_ge;
//			getchar();
//			getline(cin, factor);
			if (factor.find(" ") != string::npos) {
				mars_shi = factor.substr(0, factor.find(" "));
				mars_ge = factor.substr(factor.find(" ") + 1, factor.length() - 1 - factor.find(" "));
				ans = mars_decimal[mars_shi] * 13 + mars_single[mars_ge];
				cout << ans << endl;
			}
			else {
				if (mars_single.count(factor) != 0) {
					cout << mars_single[factor] << endl;
				}
				else {
					cout << mars_decimal[factor]*13 << endl;
				}
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/84644141