Actcoder C-755

Problem Statement

You are given an integer N. Among the integers between 1 and N (inclusive), how many Shichi-Go-San numbers (literally "Seven-Five-Three numbers") are there?

Here, a Shichi-Go-San number is a positive integer that satisfies the following condition:

  • When the number is written in base ten, each of the digits 75 and 3 appears at least once, and the other digits never appear.

Constraints

  • 1≤N<109

N is an integer.


Input

Input is given from Standard Input in the following format:

N

Output

Print the number of the Shichi-Go-San numbers between 1 and N (inclusive).


Sample Input 1

575

Sample Output 1

4

There are four Shichi-Go-San numbers not greater than 575: 357,375,537 and 573.


Sample Input 2

3600

Sample Output 2

13

There are 13 Shichi-Go-San numbers not greater than 3600: the above four numbers, 735,753,3357,3375,3537,3557,3573,3575 and 3577.


Sample Input 3

999999999

Sample Output 3

26484

题目大意:

给您一个整数N。在1到N(含)之间的整数中,有多少个只包含 数字3,5,7且都至少出现一次

题解:

从零开始,等于每次加在尾数加三或者五,七之和(用三个bool类型表示3,5,7是否存在)

#include<iostream>
using namespace std;
long long n;
int dfs(long long x,bool A,bool B,bool C){
	if(x>n) return 0;
	long long ret=0;
	if(A&&B&&C) ret++;
	ret+=dfs(x*10+7,true,B,C);
	ret+=dfs(x*10+5,A,true,C);
	ret+=dfs(x*10+3,A,B,true) ;
	return ret;
}
int main()
{
	cin >> n;
	cout << dfs(0,false,false,false)<<endl ;
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/h2017010687/article/details/84841331