新生基础训练 第六题 An easy problem

Time Limit: 1000/1000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33102
Accepted Submission(s): 21372

Problem Description :
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output
for each case, you should the result of y+f(x) on a line.

Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3

Sample Output
19
18
10
-17
-14
-4

Author
8600

Source
校庆杯Warm Up

Recommend
linle | We have carefully selected several similar problems for you: 2051 2071 2054 2052 2056

#include <iostream>
using namespace std;
int main()
{
	int x, n;
	char y;
	cin >> n;
	while (n--)
	{
		cin >> y >> x;
		if (y>=97) y =-( (int)y- 96);
		else y = (int)y - 64;
		cout << x + y << endl;
	}return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43981590/article/details/85002815