Network POJ - 1144(Tarjan求割点)

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.
Input
The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;
Output
The output contains for each block except the last in the input file one line containing the number of critical places.
Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output
1
2
Hint
You need to determine the end of one line.In order to make it’s easy to determine,there are no extra blank before the end of each line.

题意:
求割点的数量,输入有点困难…

思路:
没啥可说的,直接上Tarjan求割点模板就是了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn = 1e5 + 100;

int n, top, root, sum;
int head[maxn], dfn[maxn], low[maxn];
bool vis[maxn];

struct node 
{
    int v, next;
}edge[maxn * 2];

inline void add(int u, int v) {
    edge[top].v = v;
    edge[top].next = head[u]; 
    head[u] = top ++;
}

inline void Init() {
    top = 0;
    sum = 0;
    memset(head, -1, sizeof(head));
    memset(vis, false, sizeof(vis));
    memset(dfn, -1, sizeof(dfn));
}
//以上是建图部分

void Tarjan(int u, int father)
{
    dfn[u] = low[u] = ++sum;
    int child = 0;
    for(int i = head[u]; i != -1; i = edge[i].next) {
        int v = edge[i].v;
        if(dfn[v] == -1) {
            Tarjan(v, u);
            child ++;
            low[u] = min(low[u], low[v]);
            if(low[v] >= dfn[u] && root != u)
            {
                vis[u] = true;
            }
        }
        else if(v != father)
            low[u] = min(low[u], dfn[v]);
    }
    if(root == u && child > 1)     //根节点要特殊判一下
        vis[root] = true;
}


int main()
{
    //freopen("in.txt", "r", stdin);
    while(~scanf("%d", &n) && n)
    {
        Init();
        int num = 0;
        while(~scanf("%d", &num) && num)
        {
            int x;
            while(scanf("%d", &x))
            {
                add(num, x);
                add(x, num);
                char ch = getchar();
                if(ch == '\n')
                    break;
            }
        }
        for(int i = 1; i <= n; ++ i)    //防止题目给出的不是连通图
        {
            if(dfn[i] == -1) 
            {
                root = i;
                Tarjan(i, 0);
            }
        }
        int ans = 0;
        for(int i = 1; i <= n; ++ i)      //统计割点个数
        {
            if(vis[i])
            {
                ans++;
            }
        }
        cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/aqa2037299560/article/details/86181414