PAT (Advanced Level)1001解

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/github_38201918/article/details/86522534

因为最近在刷题库,想想就把本人可以想到的解法写到博客里,作为整理归纳。未必是最优解,还请各位高手多多包涵,能够指点指点。

题目要求
1001 A+B Format (20 分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.
Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:

-1000000 9
Sample Output:

-999,991
解题思路
回头 补充吧。。
注意事项
回头再说。。。
代码部分

#include<stdlib.h>
#include<stdio.h>
main(){
   long int a ,b,c;
  scanf("%ld %ld",&a,&b );
  c=a+b;
  int i;
  if(abs(c)>=1000&&abs(c)<1000000){
    printf("%ld,",c/1000); 
	 i=abs(c%1000);
    for(int t=3;t>0;t--){
      printf("%d",i/100);
      i=i%100;
      i=i*10;
    }

  }
  else if(abs(c)>=1000000){
    printf("%ld,",c/1000000);  
      i=abs(c%1000000/1000);
    for(int t=3;t>0;t--){
      printf("%d",i/100);
      i=i%100;
      i=i*10;
    }
    printf(",");
    i=abs(c%1000);
    for(int t=3;t>0;t--){
      printf("%d",i/100);
      i=i%100;
      i=i*10;
    }

  }
  else
  printf("%ld",c);    

}

运行结果
在这里插入图片描述

猜你喜欢

转载自blog.csdn.net/github_38201918/article/details/86522534