G - Problem G-求n的n次方结果最右边数字

Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

大致意思:给定一个正整数N,您应该输出N^N这一最右边的数字

我的见解:数字很大,所以用longlongint 看起来是挺简单的,但用常规方法一做就会超出时间限制,因为循环太久了,所以用一开始超出时间的代码来找规律 尾数是0和1的显然多少次方后仍保持不变,然后就试2的 2,12,22,32,42,52等等就可以得到规律了。

代码如下

#include <iostream>
using namespace std;


int main()
{
	int t;
	long long int n, k;
	cin >> t;
	while (t)
	{
		t--;
		cin >> n;
		k = n % 10;
		if (k == 0 || k == 1 || k == 5 || k == 6 || k == 9)
		{
			cout << k << endl;
			continue;
		}
		if(k==4)
		{
			cout << (k + 2) << endl;
			continue;
		}
		if (k == 2)
		{
			if ((((n - 2) / 10) % 2) == 0)cout << (k + 2) << endl;
			else cout << (k + 4) << endl;
			continue;
		}
		if (k == 3)
		{
			if ((((n - 3) / 10) % 2) == 0)cout << (k + 4) << endl;
			else cout << k << endl;
			continue;
		}
		if (k == 7)
		{
			if ((((n - 7) / 10) % 2) == 0)cout << (k-4) << endl;
			else cout << k << endl;
			continue;
		}
		if (k == 8)
		{
			if ((((n - 8) / 10) % 2) == 0)cout << (k - 2) << endl;
			else cout << (k - 4) << endl;
			continue;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43999137/article/details/85020514