HDU - 2612 Find a way (BFS) (day_7_F)

版权声明:商业转载请联系作者获得授权,非商业转载请注明出处。 https://blog.csdn.net/weixin_43939327/article/details/86672461

Find a way

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26746 Accepted Submission(s): 8666

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input
4 4
Y.#@

.#…
@…M
4 4
Y.#@

.#…
@#.M
5 5
Y…@.
.#…
.#…
@…M.
#…#

Sample Output
66
88
66

Author
yifenfei

Source
奋斗的年代

Recommend
yifenfei

题目简述:

小y和小N要从各自的家去肯德基,肯德基有很多家,问哪一家能使得所走路程和最小,题目给出地图。

题目分析:

广搜把到所有kfc的路程都求出来,取最小的那个。

代码实现:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cmath>
#include<queue>
//#include <bits/stdc++.h>
using namespace std;

const int INF = 0x3f3f3f3f;
#define pf          printf
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define ms(i,j) memset(i,j,sizeof(i))

int r,c,t,t1,t2,d[4][2]= {-1,0,1,0,0,-1,0,1};
char a[205][205];
bool mark[205][205];

struct s
{
    int x,y,s;
} tmp,now,END,bgn1,bgn2;

int bfs(s bgn)
{
    ms(mark,0);
    queue<s> line;
    line.push(bgn);
    mark[bgn.x][bgn.y]=1;
    while(!line.empty())
    {
        now=line.front();
        line.pop();
        if(now.x==END.x&&now.y==END.y)
        {
            return now.s;
        }
        if(now.s>t)
            return INF;
        for(int i=0; i<4; i++)
        {
            tmp= {now.x+d[i][0],now.y+d[i][1],now.s+1};
            if(tmp.x>=0&&tmp.x<r&&tmp.y>=0&&tmp.y<c&&!mark[tmp.x][tmp.y]&&a[tmp.x][tmp.y]!='#')
            {
                mark[tmp.x][tmp.y]=1;
                line.push(tmp);
            }
        }
    }
    return INF;
}

int main()
{
    vector<s> ss;
    while(~sff(r,c)&&r)
    {
        t=INF;
        while(!ss.empty())
            ss.pop_back();
        for(int j=0; j<r; j++)
        {
            scanf("%s",a[j]);
            for(int k=0; k<c; k++)
            {
                if(a[j][k]=='Y')
                    bgn1= {j,k,0};
                if(a[j][k]=='M')
                    bgn2= {j,k,0};
                if(a[j][k]=='@')
                    ss.push_back({j,k,0});
                }
        }
        while(!ss.empty())
        {
            END=ss.front();
            ss.erase(ss.begin());
            if(abs(END.x-bgn1.x)+abs(END.x-bgn1.x)>=t||abs(END.y-bgn1.y)+abs(END.y-bgn1.y)>=t)
                continue;
            t1=bfs(bgn1);
            if(t1>t)
                continue;
            t2=bfs(bgn2);
            t=min(t,t1+t2);
        }
        //sort(ss.begin(),ss.end());
        pf("%d\n",t*11);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_43939327/article/details/86672461