5 I

HDU 1576

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input
数据的第一行是一个T,表示有T组数据。

每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output
对应每组数据输出(A/B)%9973。

Sample Input
2
1000 53
87 123456789

Sample Output
7922
6060

代码如下

#include <iostream>
using namespace std;

int main()
{
	long long a, b, c, d;
	int n;
	cin >> n;
	while (n--)
	{
		cin >> a >> b;
		for (int i = 2;; i++)
		{
			c = i * b;
			if ((c - a) % 9973 == 0)break;
		}
		cout << (c / b) % 9973 << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43976373/article/details/86684210
5 I
5-1
5-2
5-8
5-3
5-9
5-6