UVA11461 Square Numbers【数学+前缀和】

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive).
Input
The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive).
Sample Input
1 4
1 10
0 0
Sample Output
2
3

问题链接UVA11461 Square Numbers
问题简述:(略)
问题分析
    求区间和问题,一般而言使用前缀和进行计算。如果前缀和需要动态维护,则需要使用树状数组或线段树。区间和可以由前缀和相减得到。
    算前缀和,事先打表是必要的。这里的前缀和数组元素prefixsum[i]定义为0-i区间平方数的个数。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA11461 Square Numbers */

#include <iostream>

using namespace std;

const int N = 1e5;
int prefixsum[N  +1] = {0};

int main()
{
    for(int i = 1, j = 1; i <= N; i++)
        if(i == j * j) {
            prefixsum[i] = prefixsum[i - 1] + 1;
            j++;
        } else
            prefixsum[i] = prefixsum[i - 1];

    int a, b;
    while(~scanf("%d%d", &a, &b) && (a || b))
        printf("%d\n", prefixsum[b] - prefixsum[a - 1]);

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10371340.html