N - Trailing Zeroes (III)(二分查找)

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

题解:零的个数可以来找5的因子个数。然后我们可以从1到1e8*5区间进行二分查找合适值。

#include<iostream>
using namespace std;
typedef long long ll;
ll f(ll x)
{
    ll ans=0;
    while(x)
    {
        ans+=x/5;
        x/=5;
    }
    return ans;
}
ll halfsearch(int x)
{
    int l=1,r=500000001,ans=0;
    while(l<=r)
    {
        int mid=(l+r)/2;
        if(f(mid)==x)
        {
            ans=mid;
            r=mid-1;
        }
        else if(f(mid)<x)
            l=mid+1;
        else
            r=mid-1;
    }
    return ans;
}
int main()
{
    ll x;
    int t;
    cin>>t;
    int k=1;
    while(t--)
    {
        cin>>x;
        int data=halfsearch(x);
        cout<<"Case "<<k++<<":"<<" ";
        if(data==0)
            cout<<"impossible"<<endl;
        else
            cout<<data<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43824158/article/details/87862205