数羊群

A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed. 


Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
InputThe first line of input contains a single number T, the number of test cases to follow. 

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.OutputFor each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description. 

Notes and Constraints 
0 < T <= 100 
0 < H,W <= 100 
Sample Input
2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###
Sample Output
6
3 
#include<iostream>

using namespace std;

int visit[200 ][200];//标记数组,标记已访问过的元素;
char grid[200][200];//储存图;

int sign(int i,int j) {//每次从图中一个点开始进行遍历,主要功能是标记已访问过的点;
	if (visit[i][j] != 1 && grid[i][j] != '.'&&grid[i][j]!='*'){//点不能被访问过,且不能不是#,否则就不是一个羊群;
		visit[i][j] = 1;
		sign(i - 1, j);
		sign(i, j - 1);
		sign(i + 1, j);
		sign(i, j + 1);
		return 1;//若果第一个点满足条件,则在递归完全结束后就会返回1;
	}
	else return 0;//如果第一个点就不是#,或被访问过则会返回0;
}

int bfs(int h,int w) {//需要把操作分为2步,每次给sign分配一个点去进行;
	int count = 0;
	for (int i = 1; i <=h; i++) {
		for (int j = 1; j <= w; j++) {
			if (sign(i,j))++count;
		}
	}
	return count;
}

int main() {
	int T, H, W;
	cin >> T;
	while (T--) {
		cin >> H >> W;
		for (int i = 0; i <= H + 1; i++) 
			for (int j = 0; j <= W + 1; j++) {
				grid[i][j] = '*';
				visit[i][j] = 0;
			}
		for(int i=1;i<=H;i++)
			for (int j = 1; j <=W; j++) 
				cin >> grid[i][j];
			
		cout << bfs(H, W) << endl;
	}
	return 0;
}
第一次写出来hahaha;


猜你喜欢

转载自blog.csdn.net/qq_41033241/article/details/80024218