动态规划——Multiplication Puzzle

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/LSC_333/article/details/78090806

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650


题意:

给n-1个矩阵排成的序列,现在让你求这n-1个矩阵相乘的最小计算量。


思路:

区间dp

n*m的矩阵和m*p的矩阵相乘的计算量是n*m*p,,这题可以把整个序列分成更小的问题,即每次都是计算第i个矩阵乘到第j个矩阵的最小计算量,记忆化搜索即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <stack>
#define INF 0x3f3f3f3f
#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
const int maxn=105;
int dp[maxn][maxn];
int a[maxn];
int n;
int work(int x, int y)   //计算x到y的最小计算量
{
    if(dp[x][y]!=INF)
        return dp[x][y];
    if(x==y)
        return dp[x][y]=0;
    else
    {
        for(int i=x; i<=y; i++)    //再次分成更小的区间
            dp[x][y]=min(dp[x][y], work(x, i)+work(i+1, y)+a[x]*a[i+1]*a[y+1]);
        return dp[x][y];
    }
}
int main()
{
    while(~scanf("%d", &n))
    {
        memset(a, 0, sizeof(a));
        memset(dp, 0x3f, sizeof(dp));
        for(int i=1; i<=n; i++)
            scanf("%d", &a[i]);
        printf("%d\n", work(1, n-1));
    }
    return 0;
}





猜你喜欢

转载自blog.csdn.net/LSC_333/article/details/78090806