二分(解方程,求导)

Now, here is a fuction: 
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) 
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534
#include<cstdio>
#include<cmath>
 #include<iostream>
 #include<algorithm>
double df(double x)
{
	return 42*pow(x,6)+48*pow(x,5)+21*x*x+10*x;
}
 
double f(double x,double y)
{
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-y*x;
}
 
int main()
{
	int t,i;
	double y,left,right,mid;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		left=0,right=100;
		for(i=1;i<=100;i++)
		{
			mid=(left+right)/2;
			if(df(mid)>y)
				right=mid;
			else
				left=mid;
		}
		printf("%.4lf\n",f(mid,y));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40859951/article/details/87469557