【最大权森林】POJ 3723 Conscription

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

POJ Monthly Contest – 2009.04.05, windy7926778


最小生成树 Kruskal emmm这个东西居然叫最大权森林  还有 用cin cout 蜜汁超时 改成scanf print才A mmp


#include <iostream>
#include <cstring>
#include <cstdio>
//#pragma GCC optimize(2)
#include<time.h>
#include <map>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
using namespace std;
#define maxn 50005
#define inf 1e18
#define eps 0.00001
typedef long long ll;
const ll mod = 1e9+7;
//const double pi = acos(-1);

struct Why
{
    int a,b,c;
}arr[maxn];

int n,m,r,T,R[maxn],ans,k;

bool cmp(Why a,Why b)
{
    return a.c < b.c;
}

ll fi(ll x)
{
    return R[x] == x? x: R[x] = fi( R[x] );
}

void slove()
{
    ll num = 0;
    for(ll i = 1; i <= r; i++)
    {
        if( fi(arr[i].a) != fi(arr[i].b)  )
        {
            ans += arr[i].c;
            R[ fi(arr[i].b)  ] = arr[i].a;
            num++;
        }

        if(num == k - 1)
            break;
    }
    return ;
}

int main()
{
    //ios::sync_with_stdio(false);
    //cin.tie(0);cout.tie(0);

    //freopen("D:\\test1.in","w",stdout);
    //srand((int)time(0));

    scanf("%d", &T);

    while(T--)
    {

        ans = 0;
        scanf("%d%d%d", &n, &m, &r);
        k = n+m;

        for(ll i = 1; i <= r; i++)
        {
            scanf("%d%d%d",&arr[i].a, &arr[i].b, &arr[i].c);
            arr[i].b += n;
            arr[i].c = -arr[i].c;
        }

        sort(arr+1,arr+1+r,cmp);

        for(ll i = 0; i < k; i++)
            R[i] = i;

        slove();

        cout << (n+m)*10000 + ans << endl;

    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/Whyckck/article/details/84259959