PAT甲级1058

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wulianwangxuchenqi/article/details/79981942

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28


最后一位为29进制,中间为17进制,进制的转换

#include<stdio.h>
int main(){
	int a1, a2, b1, b2, c1, c2;
	int a=0, b=0, c=0, m;
	scanf("%d.%d.%d %d.%d.%d", &a1, &b1, &c1, &a2, &b2, &c2);
	c = c1+c2;
	if(c>=29){
		m = c;
		c = m%29;
		b = b + m/29;
	}
	b += (b1+b2);
	if(b >= 17){
		m = b;
		b = m%17;
		a = a + m/17;
	}
	a += (a1+a2);
	printf("%d.%d.%d", a, b, c);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/wulianwangxuchenqi/article/details/79981942